API: Service Disruption
Incident Report for Area 1 Security
Postmortem

Event Details:

On October 20th, 2020 between 12:21 UTC and 16:15 UTC, the Area 1 Security API service was inaccessible and not able to service requests.

Root Cause & Actions

An incorrect configuration of the API service was deployed that limited the available memory to the service causing it to terminate. Our monitoring of service health was not functioning properly allowing this condition to remain undetected for several hours.

The Area 1 engineering team corrected the configuration issue, restoring the operation of the service. A thorough review of the monitoring system was done to correct the lack of visibility and additional safeguards have been implemented to avoid this type of issue occurring again.

Posted Oct 26, 2020 - 13:28 UTC

Resolved
The API Service experienced a disruption that began at 12:21 PM UTC and was resolved at 4:15 PM UTC. The root cause of the issue has been determined and the team has taken action to avoid further incidents of this type.
Posted Oct 20, 2020 - 12:21 UTC