Service Degradation
Incident Report for Area 1 Security
Resolved
This incident has been resolved.
Posted Oct 19, 2018 - 13:09 UTC
Investigating
Our team has noticed higher than normal email processing times and are investigating. If you are experiencing significant delays and need immediate assistance please contact support@area1security.com.
Posted Oct 19, 2018 - 12:53 UTC
This incident affected: Email Protection Service.