Email Service Domain Issue
Incident Report for Area 1 Security
Postmortem
Date / Time (UTC) Event Action
Start time: 2021-06-30 14:50 UTC Email Domain ‘mxrecord.io’ expired erroneously & prematurely Immediate escalations with our 3rd party Registrars, as well as coordination with the TLD provider.
End time: 2021-06-30 16:13 UTC Domain ‘mxrecord.io’ renewed, and updated DNS records started propagating Area 1 resolved the issue with assistance from the registrar and TLD manager of mxrecord.io

If you require additional details regarding this incident please reach out to support@area1security.com

Posted Jun 30, 2021 - 20:19 UTC

Resolved
All operations of returned to normal. A postmortem will be posted after all relevant events and data are assembled.
Posted Jun 30, 2021 - 17:24 UTC
Monitoring
The domains for our mxrecord.io domain have been restored and are propagating worldwide and email traffic is working again.
Posted Jun 30, 2021 - 16:13 UTC
Identified
The team has identified the issue and is working to restore service.
Posted Jun 30, 2021 - 15:32 UTC
Update
The team is continuing to investigate the issue with DNS for our primary delivery domain. The team is working to restore service.
Posted Jun 30, 2021 - 15:31 UTC
Investigating
The engineering team is investigating an issue with receiving journaled emails from Microsoft Office 365. All other deployments are unaffected.
Posted Jun 30, 2021 - 15:20 UTC
This incident affected: Email Protection Service.