Email Search Issues
Incident Report for Area 1 Security
Resolved
The system has been restored to full operation.
Posted Jun 30, 2022 - 19:32 UTC
Identified
The engineers have identified the issue and are working to restore service.
Posted Jun 30, 2022 - 19:23 UTC
Investigating
Cloudflare Area 1 is investigating issues related to email search functionality. We are working to mitigate the problem. More updates to follow shortly.
Posted Jun 30, 2022 - 19:17 UTC
This incident affected: Customer Portal.