Service Degradation
Incident Report for Area 1 Security
Postmortem

This was an errant notification. There were no issues with the email service during this incident. Engineers are investigating what triggered this notification.

Posted Oct 19, 2018 - 17:12 UTC

Resolved
This incident has been resolved.
Posted Oct 19, 2018 - 17:08 UTC
Investigating
Our team has noticed higher than normal email processing times and are investigating. If you are experiencing significant delays and need immediate assistance please contact support@area1security.com.
Posted Oct 19, 2018 - 17:03 UTC
This incident affected: Email Protection Service.