GCP network issues + mail through our mailstream central region is experiencing delays
Incident Report for Area 1 Security
Resolved
Cloud provider resolved issue with underlying hardware
Posted Sep 02, 2022 - 19:10 UTC
Identified
We are actively working with the cloud provider on a root cause in their network
Posted Sep 02, 2022 - 16:10 UTC
Update
The investigation continues. The impact is smaller than 0.5% of the regions traffic and delays are minimal
Posted Sep 02, 2022 - 13:48 UTC
Update
This issue is still ongoing as we are working with our google partners to further investigate this issue.
Posted Sep 02, 2022 - 13:05 UTC
Investigating
We are currently investigating this issue.
Posted Sep 02, 2022 - 12:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 02, 2022 - 12:32 UTC
This incident affected: Email Protection Service.